From: KOSAKI Motohiro Date: 2009-11-30T19:28:39+09:00 Subject: [ruby-dev:39815] Re: RbConfig.rubybin > In article <20091123.123808.1122146273169400964.kou@cozmixng.org>, > Kouhei Sutou writes: > > > ただ、メソッド名はRbConfig.rubyの方がよい気がします。 > > ちょっとチャレンジな気がしますが、それもいいかも知れませんねぇ。 > > そうするとすると、こうでしょうか。 反対に投票します。 "ruby" の4文字からパス名だと類推できる気がしないからです。 そもそも、4文字にまで縮めないといけないほど頻繁に使われるものか疑問です。 ruby_interpreter_path_super_galactica_magnum とかやたら長い名前だとしても、 APIリファレンス一発で引けるなら誰もこまらないような。