From: Akinori MUSHA Date: 2009-11-26T02:05:21+09:00 Subject: [ruby-dev:39780] [Feature #973] EncDet again チケット #973 が更新されました。 (by Akinori MUSHA) ライブラリ名は encoding でいいんじゃないですか? 将来ほかにもEncoding絡みの追加ライブラリの必要が出てきたら、 encoding/detect などに移して encoding はよく使いそうな encoding/* をすべて require (あるいはautoload)するようにすれば互換性を保てます。 またクラス名も、実装は Encoding::Detector などわかりやすい名前の下で行いつつ、 APIは(少なくともアプリケーションは)Encoding以外のクラス名を使わなくて済むように 工夫すればいいと思います。 ---------------------------------------- http://redmine.ruby-lang.org/issues/show/973 ---------------------------------------- http://redmine.ruby-lang.org