From: Tanaka Akira Date: 2009-05-17T21:25:51+09:00 Subject: [ruby-dev:38483] Re: Enumerable#gather_each In article , Yukihiro Matsumoto writes: > すでに出ていたslice_byとかがいいような気もします。 > > が、田中さんが提案している機能全部(要素削除とか)はslice_byで > は表現しきれないような気もしますが。 http://dictionary.reference.com/ で slice をひくと、 8. to cut off or remove as a slice or slices (sometimes fol. by off, away, from, etc.). とあるので、slice も削除の意味に使うことはあるようです。 -- [田中 哲][たなか あきら][Tanaka Akira]