From: Kouhei Sutou Date: 2009-02-27T19:53:23+09:00 Subject: [ruby-dev:38103] Re: [Feature:trunk] nested loop construct 須藤です。 In <86d4d5pq3f.knu@iDaemons.org> "[ruby-dev:38095] Re: [Feature:trunk] nested loop construct" on Thu, 26 Feb 2009 17:18:15 +0900, "Akinori MUSHA" wrote: > At Thu, 26 Feb 2009 14:52:05 +0900, > Yugui wrote: >> On 2/26/09 3:33 AM, Yukihiro Matsumoto wrote: >> > 検討事項は >> > * 名前。今回はnested loopということでnloopという名前で実装 >> > したが、もっと適切な名前があるかもしれない。妙な短縮形よ >> > りも長くても記述的な名前を好む人も多いかも。Ruby(というか >> > 私)は前者を好む傾向はあるけど >> >> Array#productがカルテシアン積なので、それに合わせてEnumerator#productで >> >> nphi.product(ntheta).each {} や > >  インスタンスメソッド形式は、(Array#zip 等でも感じることですが) > 3つ以上あるときに、本来対等な関係にも関わらず > > v1.product(v2, v3) > > とか > > v, *vs = *vectors > v.product(*vs) > > と「主」を立てないといけないのがどうも気に入らないんですよね。 「対象とするv全体」が「主」っぽい気がするので、 [v1, v2, v3].product がいいなぁと思いました。