From: Kouhei Sutou Date: 2008-12-11T21:05:42+09:00 Subject: [ruby-dev:37387] Re: RSS::Maker.create(version) 須藤です。 In <867i682m7h.knu@iDaemons.org> "[ruby-dev:37349] Re: RSS::Maker.create(version)" on Wed, 10 Dec 2008 22:22:07 +0900, "Akinori MUSHA" wrote: >  RSS::Maker["0.9"].new("0.91") という形ならありだと思います。 > >  しかし、 0.91 と 0.92 のクラスが同じで new() の引数で分ける、 > という実装上の都合はあまり利用者には意識させたくないですね。 > >  0.91 用にサブクラスを作り、 RSS::Maker["0.91"] と指定されたら > それを返すようにした方がいいかもしれません。 たしかにそのような気がしたので、そうしました。 ありがとうございます。 >  インスタンスを返す形だと、始めに戻ってしまいますが > > maker = RSS::Maker.create("0.91") > > の方が読みやすく感じます。create という語にはやはり強い抵抗を > お感じになるでしょうか。 はい、違うような感じがしてしまいます。 RSS::Makerにmakeとcreateという同じような作るという意味のメソッ ドが2つできるからかもしれません。 あるいは、RSS::Makerがcreateするなら、RSS::Makerオブジェクト ではなくて、RSSフィードを作るような気がしてしまうからかもしれ ません。