From: Tadashi Saito Date: 2008-10-28T01:29:23+09:00 Subject: [ruby-dev:36960] Re: prefix math_* funcs 斎藤です。 On Sun, 26 Oct 2008 01:19:01 +0900 Tadayoshi Funaba wrote: > > complex.cで使うために、いくつか数学関数からstaticがとれたようですが、 > > 外部に出すならば rb_ 接頭辞を付けてほしいです。 > > これはこうしたほうがいいんでしょうか。rb_ をつけるのは、意味が変るよう > な感じでそのままにしていただけですが、変更する場合は、今外部に見えてる > 分だけでいいですか。それとも、全部 rb_ をつけて外部にさらしたほうがいい > ですか。 とりあえず、今外部に見えている分だけで十分ではないでしょうか。 他の関数も、外部から見えるようにするときにはrb_などをつけるのが慣習だと思います。 # rb_は、名前の衝突を回避するためのある種のパッケージ名であるという認識で居ます しかし時期があれなので、Yuguiさんに許可を仰ぎたいです。 math_という如何にもありそうなが識別子が先頭にある状態で固定されてしまうのは 個人的には(きっと他のAPI利用者も)あまりうれしくないですし、他の関数に合わせる 意味でも、いかがでしょうか。 -- 斎藤ただし