From: Nobuyoshi Nakada Date: 2008-10-25T04:10:36+09:00 Subject: [ruby-dev:36919] Re: VMまわりのシンボルにも「rb_」を付けてほしい なかだです。 At Sat, 25 Oct 2008 03:30:27 +0900, Tadashi Saito wrote in [ruby-dev:36917]: > この中でdln_*とnode*は何か理由がある、と聞いたので放置しておくとすると、 dlnは、もともとがまつもとさんのrubyに依存していない独立したライ ブラリなので、rb_などはついていないということだったと思います。 nodetypeとnodelineはデバッグ用ですが、今はもう.gdbinitにnd_type やnd_lineなどがあるので消してしまっていいかも。 > もしシンボル名だけで、APIとして利用できる・して欲しくないの区別をつけるならば、 > 「rb_」の前に「_」を付けて「_rb_foo()」にする、というのはどうでしょうか。 > いかにも触りたくない感じになります。 内部用は概ねruby_になっているはずです。それに_+小文字で始まるシ ンボルは処理系定義用に予約されてませんでしたっけ。 -- --- 僕の前にBugはない。 --- 僕の後ろにBugはできる。 中田 伸悦