From: "U.Nakamura" Date: 2008-09-26T11:43:19+09:00 Subject: [ruby-dev:36597] Re: add "Error" suffix for Encoding Exceptions こんにちは、なかむら(う)です。 ちょっと引用順いじります。 In message "[ruby-dev:36593] Re: add "Error" suffix for Encoding Exceptions" on Sep.26,2008 11:31:47, wrote: > Ruby レベルのメソッドの名前と一致させて、rb_str_encode とす > るのがわかりやすいと思うんですが、どうでしょうか。 賛成します。 > 現状、static でない関数で、transcode という名前を使っているのは > > % nm -g transcode.o|grep trans > 000084a6 T Init_transcode > 000001bd T rb_declare_transcoder > 00000133 T rb_register_transcoder > 00006997 T rb_str_transcode > > という 4つだけで、上の 3つは変換エンジンの実装と密接に関係し > ているので transcode でいいのですが、文字列オブジェクトの変 > 換を行う関数の rb_str_transcode は、エンジンというより機能の > 名前です。 すみません、ついさっき1個増やしちゃいました... rb_transcode_convertibleはrb_enc_convertibleあたりですかね。 それでは。 -- U.Nakamura