From: Shyouhei Urabe Date: 2008-09-23T20:26:42+09:00 Subject: [ruby-dev:36482] [Feature #583] TmpdirとTempfile チケット #583 が更新されました。 (by Shyouhei Urabe) まあそれはそれとして自分の意見を書いておきますね。 1 tempfileとtmpdirは純粋に分かりづらすぎる。require "tmpfile"を書 いたことは思い出すだけでも片手では数え切れないくらい経験してい る。したがって改名に賛成。 2 名前としてtempfileとtmpfileなら、tmpfileのほうが好き。POSIXから の慣習に沿っている。 3 現在のtempfileの設計とか実装は好きじゃない。たとえば * Tempfile.openにブロックつけて起動したらブロックの最後でunlink してほしい。 * Process.daemonするとゴミファイルが残るのはどうにかしてほしい 4 名前を変えて再出発するなら、せっかくなので上記のような点もふく めて再設計するのがいいと思う。 ---------------------------------------- http://redmine.ruby-lang.org/issues/show/583 ---------------------------------------- http://redmine.ruby-lang.org