From: Yukihiro Matsumoto Date: 2008-06-30T23:40:18+09:00 Subject: [ruby-dev:35277] Re: some insns should be method? まつもと ゆきひろです In message "Re: [ruby-dev:35272] some insns should be method?" on Mon, 30 Jun 2008 19:46:31 +0900, SASADA Koichi writes: | alias, undef, definemethod といった,あまり使われない命令はメソッ |ド呼び出しにしたいと思うのですが,良いでしょうか. | | 具体的には,RubyVM::FrozenCore に対する特異メソッドとして実装しま |す.RubyVM::FrozenCore 自体は,freeze しておくので再定義によりその辺 |の挙動を変更することは出来ません. | ただし,set_trace_func で余計なメソッド呼び出しが見えてしまうとい |う弊害があります. | | コミットしちゃってもいいでしょうか. いいんじゃないでしょうか。