From: Kouhei Sutou Date: 2008-02-15T21:09:30+09:00 Subject: [ruby-dev:33794] Re: encdet.rb 須藤です。 In <87odajvbdx.fsf@fsij.org> "[ruby-dev:33783] Re: encdet.rb" on Thu, 14 Feb 2008 23:52:05 +0900, Tanaka Akira wrote: > > もしEncoding::Detectorになるならencoding/detector.rbがいいで > > す。 > > ディレクトリを分けるのって、あんまりいい印象がないんですが。 > test/ とか io/ とか、ディレクトリはあるけれど中には結局ひと > つしかないし。 ひとつしかないことでなにか問題があった経験があるということで しょうか? 個人的には、encdetのようなよく使われているわけではない省略名 を使った名前にはあんまりいい印象はありません。(パッと見てな にを意味しているのか分からない。) 印象とは関係ありませんが、Rubyでは名前空間をディレクトリ構造 に反映していることはわりと普通なことのように思います。 URIやWEBrickなどもそうなっている気がします。 > 今回提案しているもの以外に、なにか具体的に encoding/ 以下に > 入れたいものがありますか? 私は特にありません。 他に入れるものがあるのならディレクトリを掘るのは気にならない ということでしょうか? 言い方を変えると、encoding/以下に入るものがこれ以上増える可能 性が0であれば、encoding/は作りたくないということでしょうか? > > ところで、変えるのはファイル名とモジュール名だけですか? > > メソッド名や定数名も変えてほしいです。(Detectors -> DETECTORS) > > あぁ、DETECTORS に変えるのはとても適切ですね。これはそうしま > しょう。 ありがとうございます。