From: Tanaka Akira Date: 2008-02-14T23:52:05+09:00 Subject: [ruby-dev:33783] Re: encdet.rb In article <20080214.203702.439940124859613817.kou@cozmixng.org>, Kouhei Sutou writes: > もしEncoding::Detectorになるならencoding/detector.rbがいいで > す。 ディレクトリを分けるのって、あんまりいい印象がないんですが。 test/ とか io/ とか、ディレクトリはあるけれど中には結局ひと つしかないし。 今回提案しているもの以外に、なにか具体的に encoding/ 以下に 入れたいものがありますか? > ところで、変えるのはファイル名とモジュール名だけですか? > メソッド名や定数名も変えてほしいです。(Detectors -> DETECTORS) あぁ、DETECTORS に変えるのはとても適切ですね。これはそうしま しょう。 メソッド名については、open は変えなくていいだろうと思ってい ます。detect_encoding にはそれほどこだわりはありませんが、ファ イル名やモジュール名が先かなぁ。 -- [田中 哲][たなか あきら][Tanaka Akira]