From: "NARUSE, Yui" Date: 2007-09-28T18:12:51+09:00 Subject: [ruby-dev:31890] Re: [m17n] String#encode 成瀬です。 Yukihiro Matsumoto wrote: > encodeという名前は変換をイメージさせるのでよくないなあと思う > ようになりました。しかし、ま、名前は後で変えることにしてコミッ > トしてくださいませんか? 変換なしに文字コード名を差し替えるだけの場合は String#encoding= で、 変換を伴う場合は String#encode というのはどうなのでしょう。Shift_JIS を CP932 に差し替えるとか、バイト列に文字コードを教える場合に便利そうだなぁと。 # 個人的には encode よりも convert の方がしっくりくるのですが -- NARUSE, Yui DBDB A476 FDBD 9450 02CD 0EFC BCE3 C388 472E C1EA