From: SASADA Koichi Date: 2007-06-04T10:51:57+09:00 Subject: [ruby-dev:30878] Re: Supporting Fiber  ささだです。 Leonard Chin さんは書きました: > On 6/1/07, Nobuyoshi Nakada wrote: >> それは全部Aが主語でBが目的語ですよね。今のFiber#passでは >> Fiber.currentからレシーバに制御が渡るので、方向が逆ではないかと >> 思います。Fiberのクラスメソッドなら >> >> Fiber.bestow(fiberB) >> >> でもいいのでしょうが。 >> >> なにか、「任される」というような単語はないでしょうか。 > > すみません、勘違いしました。確かに、逆の場合(レシーバから引数 > に制御がわたる場合)を考えていました。 > > 「任される」ならば: > Fiber#take_over # "Fiber A takes over" > Fiber#usurp # "Fiber A usurps control" > Fiber#accede # "Fiber A accedes control from B" > Fiber#succeed # "Fiber A succeeds B" ちょっと継承の意味合いがある > > 上記のうち、Fiber#take_overの語感が結構いいと思います。 > 例) > next_fiber.take_over >  いろいろな案、ありがとうございます。ただ、値も一緒に渡すとな ると、それもちょっと違うかなぁという気がしています。とりあえ ず、Fiber#yield にしています。  Rubinius の人たちは Task.current= というメソッドで切り替える らしい。斬新(値は渡せないんだけど)。 -- // SASADA Koichi at atdot dot net