From: Urabe Shyouhei Date: 2007-02-26T15:09:20+09:00 Subject: [ruby-dev:30427] Re: Arrayのメソッド増強について 卜部です。 Tadashi Saito wrote: > 加えて「重複のないselect」という意味合いも、名前からは伝わらないと思い > ます。 > 重複のないselectという意味合いが意図されていたか?というのが若干疑問なの で青木さんに聞きたいところです。 takeWhile (<'n') "eieio" => "eiei" でHaskellだとちゃんと重複*する*ので。