From: SASADA Koichi Date: 2007-02-06T14:53:53+09:00 Subject: [ruby-dev:30282] Re: getinstancevariable2  ささだです. Yukihiro Matsumoto wrote: > In message "Re: [ruby-dev:30280] Re: getinstancevariable2" > on Tue, 6 Feb 2007 14:24:14 +0900, SASADA Koichi writes: > > |> 名前を変えることには賛成です。良い名前がパッと思いつかなかっ > |> たので、とりあえずの名前のつもりでしたから。機能はクラスロー > |> カルインスタンス変数であってます。 > | > | (get|set)instancevariable に is_local という命令オペランドを追加しまし > |た.こんなんでどうでしょうか. > > 私から言う立場ではないような気がするんですが、ソフトウェアVM > 的にはオペランドを追加して毎回分岐するよりも命令を増やした方 > が有利ではないですか?  YARVのデザインポリシーとしては,その辺はオペランド融合で解決するという 方針です.あと,Cに変換しても,同じような最適化が期待できます. -- // SASADA Koichi at atdot dot net