From: Yukihiro Matsumoto Date: 2007-02-06T14:29:46+09:00 Subject: [ruby-dev:30281] Re: getinstancevariable2 まつもと ゆきひろです In message "Re: [ruby-dev:30280] Re: getinstancevariable2" on Tue, 6 Feb 2007 14:24:14 +0900, SASADA Koichi writes: |> 名前を変えることには賛成です。良い名前がパッと思いつかなかっ |> たので、とりあえずの名前のつもりでしたから。機能はクラスロー |> カルインスタンス変数であってます。 | | (get|set)instancevariable に is_local という命令オペランドを追加しまし |た.こんなんでどうでしょうか. 私から言う立場ではないような気がするんですが、ソフトウェアVM 的にはオペランドを追加して毎回分岐するよりも命令を増やした方 が有利ではないですか?