From: SASADA Koichi Date: 2007-02-06T14:24:14+09:00 Subject: [ruby-dev:30280] Re: getinstancevariable2  ささだです. Yukihiro Matsumoto wrote: > | getinstancevariable2 という名前ですが、見ても何がなんだかさっぱりわか > |らないので名前をもうちょっと考えませんか。機能としては、クラスローカルイ > |ンスタンス変数でしたっけ。 > > 名前を変えることには賛成です。良い名前がパッと思いつかなかっ > たので、とりあえずの名前のつもりでしたから。機能はクラスロー > カルインスタンス変数であってます。  (get|set)instancevariable に is_local という命令オペランドを追加しまし た.こんなんでどうでしょうか. -- // SASADA Koichi at atdot dot net