From: Yukihiro Matsumoto Date: 2007-01-23T14:46:07+09:00 Subject: [ruby-dev:30167] Re: := operator まつもと ゆきひろです In message "Re: [ruby-dev:30164] Re: := operator" on Tue, 23 Jan 2007 13:03:23 +0900, SASADA Koichi writes: | うーん。せめて var a のほうが、個人的にはいいんですが。Ruby 的にはそっ |ちのほうがキモイかな。 たぶん。あと、あんまり予約語増やしたくないです。 | これは納得しました。やっぱり、ブロックローカル変数の「宣言」が何らかの |形で必要になっちゃうってことですよね。 そういうことです。で、もともと代入を宣言の代わりに使っていた ので、新しい「宣言」もなんらかの代入演算子が良いと思います。 「:=」以外のアイディアがあれば参考にします。 まつもと ゆきひろ /:|)