From: Hidetoshi NAGAI Date: 2007-01-12T23:42:47+09:00 Subject: [ruby-dev:30124] Re: Ruby/Tk クラス名のゆれ 永井@知能.九工大です. From: Kazuhiro Yoshida Subject: [ruby-dev:30080] Ruby/Tk クラス名のゆれ Date: Fri, 5 Jan 2007 11:53:02 +0900 Message-ID: <459DBD7A.2080801@moriq.com> > Ruby/Tk にはいくつかクラス名のゆれがありますが、 > マニュアルを作成する上で、どちらかに統一したいです。 いいかげんな作りですみません.<_O_> > 例えば、BLT Tileのcheckbuttonは、 > Tk::BLT::Tile::Checkbuttonの名前で定義され、 > TkCheckbuttonを継承しています。 > そして、Tk::BLT::Tile::CheckButtonを別名として用意しています。 (snip) > これはできればBLT Tileの定義をTkに合わせ、次のように変更して > 名前をCheckButtonに統一したいです(少なくともマニュアル上は)。 「両方の名前が使えればいいだろう」という程度の甘い考えでした.(^_^; ただ,Tcl/Tk のコマンド名は checkbutton ですから, どちらかと言えば TkCheckButton が良くないようにも思います. どうしましょうかねぇ... 置き換えてしまってもさしたる問題はないとは思うのですが... # 今はいろいろと手一杯だし... Tk::Checkbutton などにした方がグローバルな名前空間への影響が 抑えられていいかなと考えたこともあったのですが, 互換性のことを考えて放置してます. > あと、ほかには… > > tk/scrollable.rb: > module X_Scrollable > > tk/scrollbar.rb: > class TkXScrollbar > _ の付け方に統一感がない。 おっしゃる通りです. 名前を付けるときに迷ってフラフラしているのがそのまま出てしまってますね. 過去に「すべてアンダースコアなしに」と思ったこともあったのですが, そうすると分かりづらくなるケースがあって踏み切れなかったような 記憶もあります. ただ,どんなケースだったかは完全に忘れてしまっているので, 気のせいかもしれません. > tk/canvas.rb: > class TkCanvas include TkCanvasItemConfig > - include Scrollable > + include Tk::Scrollable > autoloadに頼っているように見える(module Tkの外にある)ので、 > このように変更したい。 あぁ,なるほど. これをやるとすると,修正個所は結構たくさんになるかもしれませんね. > など、個人的な要望としてあります。 「など」というところが気になります.(^_^) 良かったら聞かせてください. > あと、些細なtypo: ありがとうございます.手が空いたら修正しておきます. # う〜む.宿題がたまる一方だなぁ... -- 永井 秀利 (九工大 知能情報) nagai@ai.kyutech.ac.jp