From: Hidetoshi NAGAI Date: 2005-08-04T12:25:03+09:00 Subject: [ruby-dev:26737] Re: refactoring tcltklib.c (deleted ip check) 永井@知能.九工大です. From: H.Yamamoto Subject: [ruby-dev:26736] Re: refactoring tcltklib.c (deleted ip check) Date: Thu, 4 Aug 2005 03:57:37 +0900 Message-ID: <20050804035736.2969AF88.ocean@m2.ccsnet.ne.jp> > うーん、そういうことですか。私は include Tk::Tile した時に > 他のモジュールのクラスと競合しないように Tile の T が > ついているのかと思っていました。 幾種も拡張ライブラリがありますから, すべてには付けていられませんので.(^_^) 連想しやすいように基本的には Tcl/Tk と同じ名前をとしてます. # 悩ましいケースもしばしばありますが... > >まぁ,確かに一貫性を欠くというのは言えそうですので, > >以下のような patch ではいかがでしょう? > > このパッチですが、Scale として使っても WidgetClassName が TScale というのは > 問題ないでしょうか? これは問題ないです. WidgetClassName はそのウィジェットのリソースデータベースでの クラス名を表しています. ::ttk::scale .sc で作成しても,winfo class .sc の戻り値は TScale になっているはずです. ですから,WidgetClassName は TScale でなければなりません. > それは抜きにしても、一貫性をとるために冗長性が導入されて > しまうというのは、少なくとも私の手ではコミットしづらいものがあります。 Tcl/Tk の ::ttk::button コマンドからの連想を考えると 意味があるかと思います. # その意味でも TTreeview というのはやりすぎに思えるわけです. > 個人的には TScale を Scale に変えて TScale を残さないというのが > すっきりする気がするのですが、1.8.2 のリリース時にすでに Tk::Tile::TButton > などが入ってるので難しいでしょうね・・・ はい.消せないでしょうね.(^_^; -- 永井 秀利 (九工大 知能情報) nagai@ai.kyutech.ac.jp