From: keiju@... (=?ISO-2022-JP?B?GyRCQFBETTc9PHkbKEI=?= ) Date: 1997-08-25T14:32:56+09:00 Subject: [ruby-dev:241] Re: Class#eval [Re: ftplib.rb revision 1.4] けいじゅ@日本ラショナルです. In [ruby-dev :00234 ] the message: "[ruby-dev:234] Re: Class#eval [Re: ftplib.rb revision 1.4] ", on Aug/25 13:04(JST) matz@netlab.co.jp (Yukihiro Matsumoto) writes: >まつもと ゆきひろです >|どっちの動作も一理あると思うんですが, やはり間違いやすいので, 名前を変 >|えた方が良いんじゃないでしょうか? > >そうか.そうすると三つのeval群の名前を考えないといけませんね. > >Object#evalはは現行のままとして,Module#evalとオブジェクトに >固有なpublicなevalとそれぞれ良い名前はありませんかね. うーん.... Module#eval -> module_eval meval Object#eval(public) -> single_eval singular_eval singleton_eval seval object_eval oeval evalから離れるというてもあるけど, かえって分かりにくくなりそうだし... ># なんか悩みの1/3は名前の悩みのような…. ですねえ... ``良い名前が見つかればそれは正しいクラス(抽出)である.''と いうことわざ(?)もありますしねえ... 名前が決まらないってことは, 良くな い関数なのかしらん... PS. いま, Module#evalにはまっているのですが... Module#evalのなかで定義したメソッドを呼び出すと, どっかにいってしまい ます... 単純に定義しただけでは再現しないので, 簡単に再現するプログラム を作成中です. __ ..........................................石塚 圭樹@日本ラショナル... ----------------------------------->> e-mail: keiju@bc.mbn.or.jp <<---