From: "H.Yamamoto" Date: 2004-04-02T12:02:53+09:00 Subject: [ruby-dev:23306] Re: [proposal] new function for mathing path name 山本です。 matz@ruby-lang.org (Yukihiro Matsumoto) wrote: (2004/04/02 08:07) >|I wrote: >|(In this mail) >|> これと並列なものがあれば便利だと思うんです。 >| >|そもそもこれが勘違いなのでしょうか? > >うむ、山本さんは親切すぎるのではないかと(笑)。 > >この件で私が感じたのは、casefoldな環境かどうかを検出するのに >RUBY_PLATFORMを正規表現マッチして検出するのはあまりにも不親 >切だということです。で、それに対応するのに最小限必要なのが >FNM_SYSCASEのようなものではないかと。 > > File.fnmatch(path, File::FNM_PATHNAME | File::FNM_SYSCASE) > >のように呼びたいケースが頻繁にあることが分かっているならとも >かく、そうでなければ積極的に支援する必要はなさそうに思います。 > >せいぜい > > FNM_PATH = FNM_PATHNAME | FNM_SYSCASE > >のようなフラグを用意すると、より親切といった程度で十分なので >はないでしょうか。名前には議論の余地ありですが。 そうですね・・・まさにこのケースが頻繁にあると思ったので、それをデフォルトにしたかったわけなのですが、 組み込みライブラリの仕様を変える動機としては弱かったかもしれません。File.match? は取り下げます。 FNM_SYSCASE や FNM_PATH ですが、なんとなくこういうフラグを増やすのには抵抗があります。反対というほど ではないのですが、ad hok な感じがして・・・必要だということならば、反対はしません。