From: Tanaka Akira Date: 2004-03-29T19:34:01+09:00 Subject: [ruby-dev:23259] Re: IO#readpartial In article <87brmgi65x.fsf@serein.a02.aist.go.jp>, Tanaka Akira writes: >> 名前が気に入りません。でもnonblockだと別の印象を与えちゃうし >> なあ。 > read_available > read_buffered 考えたんですが、塊を読むという意味で readchunk ってのはどうですかね。 どういうときにブロックするかという情報は名前に入っていないことになって しまいますが。 -- [田中 哲][たなか あきら][Tanaka Akira]