From: toyofuku@... Date: 1998-04-08T21:23:18+09:00 Subject: [ruby-dev:2201] Re: new coerce 豊福@パパイヤです。 まつもとさん > 現時点では > coerceは「数(ちょっと曖昧な領域ですが)」に限定した方が望まし > いと思ってます. 私も現実的に coerce が必要になるのは「数」的なものしか ないだろうと思います。 ただ「限定」の仕方なんですが、 「Calculatableモジュールのようなものを設けてそれを include しているものしか coerce を持っちゃいけない」 というように限定するのか、 「どのオブジェクトも coerce を持っても構わないのだが 実際には「数」的なものだけにしか coerce を実装しない」 というようにするのか、またはそれ以外の方法でしょうか。 モジュールを設けるとするとその名前を決めるのにどうしても 「coerceとは」や「数とは」の方に意識がいってしまいます。 --- 豊福@パパイヤ unbound@papaya.juice.or.jp toyofuku@juice.or.jp