From: Takaaki Tateishi Date: 2003-11-08T14:17:06+09:00 Subject: [ruby-dev:21877] Re: get_last_error or getLastError by DL::Importable At Sat, 8 Nov 2003 13:10:55 +0900, > を見て違和感を感じたのですが、DL::Importable は元の名前が「GetLastError」 > のときに「getLastError」という奇妙な名前に変換するようです。美しくないで > す。なぜ、get_last_error というような名前に変換しないのでしょうか? 理由は大したことではないのです.最初が大文字はRubyでは定数(だけどメソッド として呼ぶことはできる)なので先頭だけ小文字にして,javaみたいな感じでもい いかなと思ったのと,なるべく元の名前を残した方がいいかもしれないという考え から当時そうしていたのだと思います. 実は最近 GetLastError() のように名前を変えて欲しくないという要望も一件きた ばかりです.モジュールをincludeすることで名前の変換を行なうメソッドを置き 換えて,好みに応じて使い分けるというのはどうでしょう? あとは,僕以外ですでに使っている人がどう思うかなんですが… せっかくの機会なので,どこかのWebページで多数決をとりたいと思うのですがい かがでしょう? # それぞれの名前の付け方の呼び名はなんて言うんでしょう? -- Takaaki Tateishi