From: matz@... (Yukihiro Matsumoto) Date: 2003-02-08T03:08:46+09:00 Subject: [ruby-dev:19534] Re: HAVE_* macros まつもと ゆきひろです In message "[ruby-dev:19533] Re: HAVE_* macros" on 03/02/08, "Akinori MUSHA" writes: |> |> +#define HAVE_3ARY_RB_CVAR_SET |> | |> |HAVE_RB_CVAR_SET__WITH_WARNとか…。 | | これは HAVE_RB_CVAR_DECLARE にしておきますか。autoconf を参考に |しようと思ったけど、格好の例は見つかりませんでした。getpgrp() が |引数を取らない場合に GETPGRP_VOID を定義することと、 select() の |引数の型を SELECT_TYPE_ARG1 などに定義しているのを見ると、語順的 |には RB_CVAR_SET_4ARGS というのが妥当かも。 これらはそんなにイヤじゃありません。自分でも基準がよくわから ないけど。これらならどっちでも良いです。 |> これらが良いな。NORETURN_STYLEは |> |> RUBY_NORETURN_STYLE_xxxx |> |> という名前のほうがよいと思うけど(でも思いつかない)。 | | 今後変わる可能性はないと思うので、 NORETURN_STYLE_NEW でもOK? んじゃそういうことで。