From: Akinori MUSHA Date: 2003-02-08T01:35:00+09:00 Subject: [ruby-dev:19533] Re: HAVE_* macros At Sat, 25 Jan 2003 09:45:43 +0900, matz wrote: > |> +#define HAVE_3ARY_RB_CVAR_SET > | > |HAVE_RB_CVAR_SET__WITH_WARNとか…。  これは HAVE_RB_CVAR_DECLARE にしておきますか。autoconf を参考に しようと思ったけど、格好の例は見つかりませんでした。getpgrp() が 引数を取らない場合に GETPGRP_VOID を定義することと、 select() の 引数の型を SELECT_TYPE_ARG1 などに定義しているのを見ると、語順的 には RB_CVAR_SET_4ARGS というのが妥当かも。 > これらが良いな。NORETURN_STYLEは > > RUBY_NORETURN_STYLE_xxxx > > という名前のほうがよいと思うけど(でも思いつかない)。  今後変わる可能性はないと思うので、 NORETURN_STYLE_NEW でもOK? -- / /__ __ Akinori.org / MUSHA.org / ) ) ) ) / FreeBSD.org / Ruby-lang.org Akinori MUSHA aka / (_ / ( (__( @ iDaemons.org / and.or.jp "It went right by me -- At the time it went over my head I was looking out the window.. I should have looked at your face instead"