From: matz@... (Yukihiro Matsumoto) Date: 2003-01-25T09:45:43+09:00 Subject: [ruby-dev:19436] Re: HAVE_* macros まつもと ゆきひろです In message "[ruby-dev:19435] Re: HAVE_* macros" on 03/01/24, nobu.nakada@nifty.ne.jp writes: |> +#define HAVE_RB_DEFINE_ALLOC_FUNC | |これはhave_funcそのままなので、いいんじゃないでしょうか。 | |> +#define HAVE_3ARY_RB_CVAR_SET | |HAVE_RB_CVAR_SET__WITH_WARNとか…。 | |> +#define HAVE_1ARY_NORETURN | |うーん、これは難しい。 | |>  NEW_ だとまた変わったときに困るし、 RUBY170_ みたいなのでは |> バージョン番号での判定を助長する感じがしてまずいと思いました。 | |開きなおって番号をふっちゃうとか。 | |#define RUBY_NORETURN_STYLE 0 /* prototype NORETURN; */ |#define RUBY_NORETURN_STYLE 1 /* NORETURN(prototype); */ これらが良いな。NORETURN_STYLEは RUBY_NORETURN_STYLE_xxxx という名前のほうがよいと思うけど(でも思いつかない)。 matz.