From: matz@... (Yukihiro Matsumoto) Date: 2002-12-20T17:39:24+09:00 Subject: [ruby-dev:19140] Re: zlib (was: Re: Re: ruby 1.6.9 preview4 予告) まつもと ゆきひろです In message "[ruby-dev:19139] zlib (was: Re: Re: ruby 1.6.9 preview4 予告)" on 02/12/20, UENO Katsuhiro writes: |メソッドを分けるというのは良いアイディアだと思います。 | | close! … ファイルも一緒に閉じる | close … 圧縮ストリームのみ閉じる | |ではなくて、 | | close … ファイルも一緒に閉じる | <何か> … 圧縮ストリームのみ閉じる | |という方向ではどうでしょう。 賛成。でも、名前が思いつかないなあ。close_compressとか一瞬考 えたけど、きっと圧縮の終了を意味するだけなので本当にふさわし い名前はcloseではないのだろうという気がするのです。