From: matz@... (Yukihiro Matsumoto) Date: 2002-11-19T17:33:11+09:00 Subject: [ruby-dev:18847] Re: Enumerable#zip まつもと ゆきひろです In message "[ruby-dev:18846] Re: Enumerable#zip" on 02/11/19, Tanaka Akira writes: |> なるほど。でも、こういうのは zip ではなく transpose と呼ぶの |> ではないですか。Array#transpose(が適切な名前であるならば)導 |> 入には反対しません。 | |なるほど。 なんとなく、Array#transposeを作ってCVSに突っ込んでみました。 現状では要素数があわないとIndexErrorを出します。IndexErrorで 良いかっていうと疑問が残るんですが。 |次回(あるいは今後数回)誰かがリクエストをした時に長さが揃っていない状況 |の望ましい扱いかたを尋ねてからでも入れるのは遅くないかも。 正論です。 |それはそれとして、iterate_with という名前を見て思い付いたのですが、いっ |そ(やはりボキャブラリの増加を押えて) each_with かなぁ、とか。とくにそ |うして欲しいというわけではなく、思い付いた名前は出しておこうかというだ |けなんですけど。 each_withは良いかも。 とはいうものの、現状ではEnumerable#zipを * レシーバの長さに合わせる(足りなければnil、余れば無視) * ブロックが与えられたらsync_each(each_with)的動作をする ようにしてみました。