From: matz@... (Yukihiro Matsumoto) Date: 2001-09-12T16:50:38+09:00 Subject: [ruby-dev:14777] Re: forwardable.rb : call Kernel.raise まつもと ゆきひろです In message "[ruby-dev:14762] Re: forwardable.rb : call Kernel.raise" on 01/09/09, 石塚圭樹 writes: |うーん. その再定義されたraiseは、オリジナルのraiseと違う目的なんですか? |違う目的なら名前を変えるべきだし、同じ目的なら、オリジナルのraiseと同じ |振る舞いをすべき、つまり、こちらがraiseを呼んでも問題ないようにすべきだ |と思いますが? まあ、Tkのraiseのように元々のライブラリが提供している名前が raiseなので、raiseこそが(オリジナルのraiseとは意味が違うにし ても)最も適切な名前というケースもありえますから、いずれにし てもKernel::raise にしておいた方が良いように思います。