From: Akinori MUSHA Date: 2001-07-24T22:57:00+09:00 Subject: [ruby-dev:14034] Re: [ruby-cvs] ruby: * ruby.h: fix a wrong function name: rb_iglob() -> rb_globi().  ちょっと間が空きましたが Dir::fnmatch の件です。 At Mon, 16 Jul 2001 23:18:20 +0900, Yukihiro Matsumoto wrote: > | 名前については、 fnmatch() -> rb_fnmatch() を提案しています。 > |fnmatch() のないプラットフォームもあるし、将来のマルチバイト対応 > |などもにらんで Ruby として提供する機能の一つとして見ればおかしく > |ないと思いますよ。 > > regex.cにならえば ruby_fnmatch でしょうね。そっちの方が妥協  なるほど。ruby_fnmatch() にします。 > できるなあ。RB_FNM_*という定数名もけっこう気になってます。  気になるというのはどの辺りでしょうか?以下にいくつか代替案を。 (私の希望順) a. RUBY_FNM_* [長いが自然] b. FNM_RUBY_* [長いがやや自然] c. マクロは用意せず、数値を使う [意味不明瞭, 将来困りそう] d. FNM_* (システムにあっても #undef して再定義) [危険] e. その他 -- / /__ __ Akinori.org / MUSHA.org / ) ) ) ) / FreeBSD.org / Ruby-lang.org Akinori MUSHA aka / (_ / ( (__( @ iDaemons.org / and.or.jp "Freeze this moment a little bit longer, make each impression a little bit stronger.. Experience slips away -- Time stand still"