From: eregontp@...
Date: 2020-03-29T15:19:38+00:00
Subject: [ruby-core:97618] [Ruby master Feature#16742] RbConfig.windows? and	RbConfig.host_os

Issue #16742 has been updated by Eregon (Benoit Daloze).


Also worth nothing `RUBY_PLATFORM =~ /(mswin|mingw)/` is hacky and incomplete, and there are many subtle variants of that check such as `RUBY_PLATFORM =~ /win32|mingw|bccwin|cygwin/`.
`RbConfig.windows?` would be far more reliable and easier to read.

----------------------------------------
Feature #16742: RbConfig.windows? and RbConfig.host_os
https://bugs.ruby-lang.org/issues/16742#change-84809

* Author: Eregon (Benoit Daloze)
* Status: Open
* Priority: Normal
----------------------------------------
I think adding these two methods would greatly clarify platform checks:
```
RbConfig.windows? # obvious, much clearer than RUBY_PLATFORM =~ /(mswin|mingw)/
RbConfig.host_os # same as RbConfig::CONFIG['host_os'], but much shorter
```

`RbConfig::CONFIG['host_os']` is too long and feels like digging in the internals even though it's such a simple thing to query.


For comparison, there is already a `RbConfig.ruby` method on `RbConfig`, which helps avoiding the boilerplate to access RbConfig::CONFIG manually.

Thoughts?



-- 
https://bugs.ruby-lang.org/

Unsubscribe: <mailto:ruby-core-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-core>