From: Mauricio Fernandez Date: 2006-10-12T22:47:45+09:00 Subject: Commit miss? Hash#identical vs. Hash#compare_by_identity Right now, I can see Hash#identical and Hash#identical? in CVS HEAD. However, in the Changelog we have: Tue Sep 12 21:24:54 2006 Yukihiro Matsumoto * hash.c (rb_hash_compare_by_identity): rename Hash#identical to Hash#compare_by_identity. Looking into this some more, it seems that it was originally #identical: http://www.ruby-lang.org/cgi-bin/cvsweb.cgi/ruby/hash.c.diff?r1=1.167;r2=1.168 It was renamed to #compare_by_identity shortly after the initial patch http://www.ruby-lang.org/cgi-bin/cvsweb.cgi/ruby/hash.c.diff?r1=1.168;r2=1.169 but the latter was reverted a couple days later http://www.ruby-lang.org/cgi-bin/cvsweb.cgi/ruby/hash.c.diff?r1=1.169;r2=1.170 and the code has remained that way since then. The ChangeLog entry and the CVS history (as well as the fact that #compare_by_identity seems better than #identical) make me think that the last modification was unintended. -- Mauricio Fernandez - http://eigenclass.org - singular Ruby