From: Joel VanderWerf Date: 2006-10-12T03:21:03+09:00 Subject: Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use "to_splat" instead of "to_ary" to Brown, Warren wrote: >> to_a was too general. All enumerable objects (and even >> more) have to_a method. to_ary was too narrow. Only >> array compatible objects have to_ary. I wanted >> something in between. > > Without sounding too flippant, why not "to_ar"? It would be "in > between" to_a and to_ary in all senses. It would very easy to remember > too. I thought that method was used to render strings into Pirate-speak. "Hello".to_ar # ==> "Avast!" -- vjoel : Joel VanderWerf : path berkeley edu : 510 665 3407