From: Charles Oliver Nutter Date: 2006-10-11T00:30:53+09:00 Subject: Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use "to_splat" instead of "to_ary" to dblack@wobblini.net wrote: > On Tue, 10 Oct 2006, Charles Oliver Nutter wrote: >> to_splattable (perhaps most accurate; I tend to like to_splat also) > > Am I the only one who thinks that "splat" is a goofy, babyish word, > and while OK to throw around on mailing lists, really not expressive > of anything technically specific? (The most accurate would be > "to_splatted", but hopefully the whole thing can be avoided.) It > would be like having File.slurp instead of File.read. I like the word; it's very descriptive of slamming an array against a hard surface...the contents "splat" out into individual elements. If you want something more technically descriptive, "expand" is your word, or perhaps "break_into_consitutent_pieces". I like splat. And I figured to_splattable is more accurate because it hasn't been splatted yet; the implementation of to_splattable returns an array that's ready to be splatted. You could certainly call x = y.to_splattable; z = [*y]; because y is a splattable, not a splatted. -- Charles Oliver Nutter, JRuby Core Developer headius@headius.com -- charles.o.nutter@sun.com Blogging at headius.blogspot.com