From: dblack@... Date: 2006-10-11T00:23:16+09:00 Subject: Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use "to_splat" instead of "to_ary" to Hi -- On Tue, 10 Oct 2006, Charles Oliver Nutter wrote: > Thomas Enebo wrote: >> One issue with naming is if you choose something too synonymy it becomes >> difficult to separate the meaning between them: to_a, to_ary, to_list. >> No suggestion. Just an observation that new Ruby users will end up getting >> pretty confused if they cannot distinguish between these method names. >> to_splat probably will be something most new users will ignore since they >> will have no idea what a splat is. > > Of those proposed so far I like to_values best. There's no list/array > ambiguity there, and it makes sense...expand this value into values. > > I'd throw out a couple others: > > to_splattable (perhaps most accurate; I tend to like to_splat also) Am I the only one who thinks that "splat" is a goofy, babyish word, and while OK to throw around on mailing lists, really not expressive of anything technically specific? (The most accurate would be "to_splatted", but hopefully the whole thing can be avoided.) It would be like having File.slurp instead of File.read. David -- David A. Black | dblack@wobblini.net Author of "Ruby for Rails" [1] | Ruby/Rails training & consultancy [3] DABlog (DAB's Weblog) [2] | Co-director, Ruby Central, Inc. [4] [1] http://www.manning.com/black | [3] http://www.rubypowerandlight.com