From: Steven Lumos Date: 2006-10-10T07:59:58+09:00 Subject: Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use "to_splat" instead of "to_ary" to Yukihiro Matsumoto writes: > Hi, > > In message "Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use "to_splat" instead of "to_ary" to" > on Mon, 9 Oct 2006 21:30:42 +0900, dblack@wobblini.net writes: > > |The name "to_splat" is a bit problematic. Since "splat" is itself a > |verb, it's like saying "to_flatten" or "to_puts" or "to_delete". > > Um. For "to_" + verb, we already have "to_open". I am open for the > better name proposal, as always. > > matz. Not general enough, I know: to_arguments. It's almost always only going to be called '*' anyway, right? Steve