From: Yukihiro Matsumoto Date: 2006-10-10T07:20:50+09:00 Subject: Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use "to_splat" instead of "to_ary" to Hi, In message "Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use "to_splat" instead of "to_ary" to" on Tue, 10 Oct 2006 01:56:17 +0900, dblack@wobblini.net writes: |I like to_list. It's specific enough that misuse/overuse will be |evident. And even though "list" isn't a core class, it's a noun and |also much more meaningful than "splat". Well, that name assumes we are converting an object into a list which in reality an array. Besides that calling parameters a list reminds me Perl too much. Now I understand how Matju felt in the original post. ;-) How about to_values? It's noun; plurality indicates it's a collection of values (which often represented by an array). to_args comes next in my preference list. matz.