From: Thomas Enebo Date: 2006-10-10T02:20:44+09:00 Subject: Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use "to_splat" instead of "to_ary" to dblack@wobblini.net wrote: > Hi -- > > On Tue, 10 Oct 2006, James Edward Gray II wrote: > >> On Oct 9, 2006, at 11:50 AM, Eero Saynatkari wrote: >> >>> On 2006.10.10 00:31, James Edward Gray II wrote: >>>> On Oct 9, 2006, at 10:19 AM, dblack@wobblini.net wrote: >>>> >>>>> Hi -- >>>>> >>>>> On Mon, 9 Oct 2006, Yukihiro Matsumoto wrote: >>>>> >>>>>> Hi, >>>>>> >>>>>> In message "Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use >>>>>> "to_splat" instead of "to_ary" to" >>>>>> on Mon, 9 Oct 2006 23:06:57 +0900, dblack@wobblini.net writes: >>>>>> >>>>>> |> Um. For "to_" + verb, we already have "to_open". I am open >>>>>> for the >>>>>> |> better name proposal, as always. >>> ... >>>> to_params >>> >>> Yep, or to_parms, to_list (to_parameterlist is probably a bit long:) >> >> to_args is probably a bit more Rubyish, since *args is an oft-seen >> idiom. > > I think, though, that the goal is to have a way to define *anything > behavior, in ways that go beyond the arglist use case. One issue with naming is if you choose something too synonymy it becomes difficult to separate the meaning between them: to_a, to_ary, to_list. No suggestion. Just an observation that new Ruby users will end up getting pretty confused if they cannot distinguish between these method names. to_splat probably will be something most new users will ignore since they will have no idea what a splat is. -Tom "Stater of the obvious"