From: dblack@... Date: 2006-10-10T02:06:18+09:00 Subject: Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use "to_splat" instead of "to_ary" to Hi -- On Tue, 10 Oct 2006, James Edward Gray II wrote: > On Oct 9, 2006, at 11:50 AM, Eero Saynatkari wrote: > >> On 2006.10.10 00:31, James Edward Gray II wrote: >>> On Oct 9, 2006, at 10:19 AM, dblack@wobblini.net wrote: >>> >>>> Hi -- >>>> >>>> On Mon, 9 Oct 2006, Yukihiro Matsumoto wrote: >>>> >>>>> Hi, >>>>> >>>>> In message "Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use >>>>> "to_splat" instead of "to_ary" to" >>>>> on Mon, 9 Oct 2006 23:06:57 +0900, dblack@wobblini.net writes: >>>>> >>>>> |> Um. For "to_" + verb, we already have "to_open". I am open >>>>> for the >>>>> |> better name proposal, as always. >> ... >>> to_params >> >> Yep, or to_parms, to_list (to_parameterlist is probably a bit long:) > > to_args is probably a bit more Rubyish, since *args is an oft-seen idiom. I think, though, that the goal is to have a way to define *anything behavior, in ways that go beyond the arglist use case. David -- David A. Black | dblack@wobblini.net Author of "Ruby for Rails" [1] | Ruby/Rails training & consultancy [3] DABlog (DAB's Weblog) [2] | Co-director, Ruby Central, Inc. [4] [1] http://www.manning.com/black | [3] http://www.rubypowerandlight.com [2] http://dablog.rubypal.com | [4] http://www.rubycentral.org