From: dblack@... Date: 2006-10-10T01:27:15+09:00 Subject: Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use "to_splat" instead of "to_ary" to Hi -- On Tue, 10 Oct 2006, Yukihiro Matsumoto wrote: > Hi, > > In message "Re: [ruby-cvs:18323] ruby: * eval.c (splat_value): use "to_splat" instead of "to_ary" to" > on Tue, 10 Oct 2006 00:19:04 +0900, dblack@wobblini.net writes: > > |> You mean "to_star"? I like the "to_" name for internal conversion > |> methods. > | > |I actually meant just "starred", without the to_. I'm not sure the > |to_ makes sense. With the conversions (to_something), the "something" > |is always (?) a recognizable, core class: to_i, to_s, to_f, etc. But > |the star is the operation, not the result. The object isn't really > |being converted to a particular thing that can be named or labelled. > | > |to_starred is better than to_splat; it reads much better. But to_ > |still doesn't feel like the right fit for this. I'll keep > |brainstorming.... > > Hmm, you are a native English speaker, so your feeling must be > valuable input for name selection. But still I don't think neither > "starred" or "to_starred" is better than "to_splat". The term "splat" > is very specific to the operation, but "star" is not. I feel negative > about "unarray" too. What should we get from unarraying an array? A list. David -- David A. Black | dblack@wobblini.net Author of "Ruby for Rails" [1] | Ruby/Rails training & consultancy [3] DABlog (DAB's Weblog) [2] | Co-director, Ruby Central, Inc. [4] [1] http://www.manning.com/black | [3] http://www.rubypowerandlight.com [2] http://dablog.rubypal.com | [4] http://www.rubycentral.org