From: duerst@... Date: 2015-09-25T05:06:13+00:00 Subject: [ruby-core:70907] [Ruby trunk - Misc #11548] FileUtils#remove_tailing_slash is a poor method name Issue #11548 has been updated by Martin D��rst. I agree. We should probably introduce the new name now, and later deprecate the old one. ---------------------------------------- Misc #11548: FileUtils#remove_tailing_slash is a poor method name https://bugs.ruby-lang.org/issues/11548#change-54274 * Author: Ryan Hosford * Status: Open * Priority: Normal * Assignee: ---------------------------------------- One would expect this method to be called `remove_trailing_slash` I asked around on IRC and the consensus is this is probably an unfortunate typo that's survived too long. Tailing and Trailing mean similar things, but I think most would expect "trailing" to be the clear choice here. http://ruby-doc.org/stdlib-2.2.3/libdoc/fileutils/rdoc/FileUtils.html#method-i-remove_tailing_slash -- https://bugs.ruby-lang.org/