From: tad.hosford@... Date: 2015-09-24T19:50:26+00:00 Subject: [ruby-core:70900] [Ruby trunk - Misc #11548] [Open] FileUtils#remove_tailing_slash is a poor method name Issue #11548 has been reported by Ryan Hosford. ---------------------------------------- Misc #11548: FileUtils#remove_tailing_slash is a poor method name https://bugs.ruby-lang.org/issues/11548 * Author: Ryan Hosford * Status: Open * Priority: Normal * Assignee: ---------------------------------------- One would expect this method to be called `remove_trailing_slash` I asked around on IRC and the consensus is this is probably an unfortunate typo that's survived too long. Tailing and Trailing mean similar things, but I think most would expect "trailing" to be the clear choice here. http://ruby-doc.org/stdlib-2.2.3/libdoc/fileutils/rdoc/FileUtils.html#method-i-remove_tailing_slash -- https://bugs.ruby-lang.org/