From: "mrkn (Kenta Murata)" Date: 2013-06-06T16:28:39+09:00 Subject: [ruby-core:55334] [ruby-trunk - Feature #8499] Importing Hash#slice, Hash#slice!, Hash#except, and Hash#except! from ActiveSupport Issue #8499 has been updated by mrkn (Kenta Murata). zzak (Zachary Scott) wrote: > Hello, > > On Thu, Jun 6, 2013 at 4:12 PM, mrkn (Kenta Murata) wrote: > > On Rails, they can be written in the following forms by using ActiveSupport's features. > > > > (1) (({hash = other_hash.slice(:key1, :key2, :key3)})) > > (2) (({hash = other_hash.reject(:key1, :key2, :key3}})) > > Do you mean "other_hash.except(...)"? There is already Hash#reject Yes, It's my mistake! How can I edit the issue description? ---------------------------------------- Feature #8499: Importing Hash#slice, Hash#slice!, Hash#except, and Hash#except! from ActiveSupport https://bugs.ruby-lang.org/issues/8499#change-39741 Author: mrkn (Kenta Murata) Status: Assigned Priority: Normal Assignee: matz (Yukihiro Matsumoto) Category: core Target version: current: 2.1.0 =begin RD According to my experiences, the following two idioms often appeare in application codes. (1) (({hash = other_hash.select { |k, | [:key1, :key2, :key3].include? k }})) (2) (({hash = other_hash.reject { |k, | [:key1, :key2, :key3].include? k }})) On Rails, they can be written in the following forms by using ActiveSupport's features. (1) (({hash = other_hash.slice(:key1, :key2, :key3)})) (2) (({hash = other_hash.reject(:key1, :key2, :key3)})) I think the latter forms are shorter and more readable than the former ones. So I propose to import the following methods from ActiveSupport: * (({Hash#slice})) * (({Hash#slice!})) * (({Hash#except})) * (({Hash#except!})) =end -- http://bugs.ruby-lang.org/