From: Ilias Lazaridis Date: 2005-05-13T12:48:58+09:00 Subject: [CODE] - Function Naming Conventions from class.c: VALUE rb_class_boot(super) VALUE super; { NEWOBJ(klass, struct RClass); OBJSETUP(klass, rb_cClass, T_CLASS); klass->super = super; klass->iv_tbl = 0; klass->m_tbl = 0; /* safe GC */ klass->m_tbl = st_init_numtable(); OBJ_INFECT(klass, super); return (VALUE)klass; } - for naming consistency reasons OBJ_INFECT (ok) NEWOBJ -> OBJ_NEW OBJSETUP -> OBJ_SETUP - please confirm / deny the correctness of the suggestion. . -- http://lazaridis.com