From: Dice Date: 2012-06-03T10:55:18+09:00 Subject: [ruby-core:45398] Re: [RFC] RubyVM::FrameInfo.caller method Hi. > Other guy pointed out that FrameInfo is to noisy (FooInfo is bad naming > rule). �At last, we change the class name FrameInfo to Location. > >> � � � * vm_backtrace.c: change names. >> � � � � (1) Class name: RubyVM::FrameInfo -> RubyVM::Backtrace::Location. >> � � � � (2) Method name: RubyVM::FrameInfo.caller -> >> � � � � � � Kernel.caller_locations. >> � � � � (3) Instance methods of >> � � � � � � � RubyVM::FrameInfo (RubyVM::Backtrace::Location) >> � � � � � � (3-1) name -> label >> � � � � � � (3-2) basename -> base_label (basename is confusing with >> � � � � � � � � � File.basename) >> � � � � � � (3-3) line_no -> lineno (We have already similar name >> � � � � � � � � � File#lineno, commented by kou [ruby-dev:45686]). >> � � � � � � (3-4) filename -> path. >> � � � � � � (3-5) filepath -> absolute_path. >> � � � � � � (3-5) iseq -> removed (we will make other APIs to access iseq >> � � � � � � � � � and other information of frame for debugging). > > What do you think about it? I think it's better naming and design than RubyVM::FrameInfo too. It is friendly. Thank you for replying! -- Dice tetradice@gmail.com http://ruby.morphball.net/