From: Mathieu Bouchard Date: 2005-01-13T10:37:19+09:00 Subject: Re: The face of Unicode support in the future On Wed, 12 Jan 2005, trans. (T. Onoma) wrote: > On Wednesday 12 January 2005 09:19 am, Austin Ziegler wrote: > | I do believe that there was discussion regarding having a ByteVector > | sort of class, too -- resulting in the sort of speed optimisations > | necessary without impacting normal String use. > A Blob class? Why would it be called a 'vector'? Well, a better name would be ByteArray or ArrayOfByte, and it could work exactly as an Array, except for the limitations on its range of accepted values. Calling it a Vector would be in sync with what is used in many programming languages, including C++/STL, Java, CommonLisp, but Ruby already uses the name Array for exactly that kind of thing. Besides, why would it be called something completely different like Blob? Are you thinking of naming it in sync with (my)SQL, and if so, why? _____________________________________________________________________ Mathieu Bouchard -=- Montr�al QC Canada -=- http://artengine.ca/matju