From: Rodrigo Rosenfeld Rosas Date: 2011-01-19T20:54:51+09:00 Subject: [ruby-core:34602] Re: [Ruby 1.9-Feature#4264] General type coercion protocol for Ruby On 19-01-2011 08:05, mathew wrote: > On Tue, Jan 11, 2011 at 10:26, Charles Nutter wrote: >> Issue #4264 has been updated by Charles Nutter. >> >> >> I like #to better as well, but isn't it too generic a name, sure to conflict with libraries >> out there? > Two-letter method names make me uneasy. How about obj.cast(Class)? > > Or cast_to / cast_from, as in Jonas Pfenniger's patch. > > > mathew > [ Not a big fan of attr_* either ] > I like the cast_to/cast_from names and I guess it avoids conflict with most libraries. Rodrigo.